Adding Internal Links and Multimedia Elements
Adding Internal Links to a PDF Document
To create an internal hyperlink in a PDF document do the following:
1. Navigate to the section in the document where you want to create a link.
2. Select the Link Tool from the toolbar. The pointer becomes a cross hair (+).
3. Press the Ctrl key and select the target text with the I-beam. This allows you to fit a link
rectangle exactly around the selected text. With the Text Select tool cross hair (+) you
can also drag the mouse over the text to create a marquee.
4. In the Create Link dialog box, choose the rectangle type (visible or invisible).
5. Select a Highlight Option for when the link is selected (none, invert, outline or inset).
6. Choose an Action Type, which should usually be the default, Go to View.
7. Navigate down in the document to the page containing the text of the link target.
8. Click on the Set Link button.
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Adding Multimedia Elements to a PDF Document
In order to add multimedia elements (images, sounds, videos or movies, slide shows, etc.) to a
PDF document you must be using Adobe Acrobat versions 6.0 or 7.0 Professional Edition; this
cannot be done with the Standard Edition or with Acrobat 5.0 or less. Adding multimedia
elements to a PDF document involves embedding or integrating the elements into the document,
and does not involve simply creating a link to an external multimedia file, which is not allowed
in ETDs.
Adding Sound to a PDF Document
Adding Movies to a PDF Document
Adding a Multimedia Presentation to a PDF Document

Adding Sound to a PDF Document
You can add sound to a document in a variety of ways, including with images, buttons, when a
page opens, or when a page closes. Acrobat versions 6.0 or 7.0 Professional Edition now
supports sounds for all popular formats including MP3. When you add a sound to an PDF
document, you can choose to embed the sound in the document, which saves the sound with the
document rather than in a separate sound file. With ETD submissions only a single PDF file is
allowed, thus, all multimedia elements must be embedded.
When you add sound to a PDF document you can use the Sound tool to define an active area of
the document that, when clicked, plays a sound. When you use the Sound tool, you enable the
viewers to play a sound on demand by clicking the active area with the Hand tool. To add a
sound to a PDF document using the Sound tool, follow these steps:
1. Navigate to the page to which you want to add the sound file.
2. Choose Tools > Advanced Editing > Sound Tool. Alternatively, select the Sound tool
from the Advanced Editing toolbar, whose icon looks like a speaker.
3. Click and drag a rectangle inside the document to define the active area that will play the
sound when clicked. This opens the Add Sound dialog box.
4. In the Content Settings section, click a radio button to choose Acrobat 6 (or 7)
Compatible Media. If you select the Acrobat 5 (and Earlier) Compatible Media you
will not be able to embed the sound with the document.
5. Click the Browse button to open the Select Sound File dialog box; then select the
desired sound file and click Select to exit the Select Sound File dialog box.
6. If you choose Acrobat 6 (or 7) Compatible Media, the Embed Content in Document
check box is selected by default.
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7. In the Poster Setting section, choose one of the following options:
Use No Poster – Select this option to accept the default option, and the active area that
plays the sound is designated by a border whose attributes you can modify.
Create Poster From File – Select this option, and the browse button becomes available.
Click the browser button and select an image that will designate the active area for the
sound file. Note that when you select an image, its dimensions are reconfigured to fit the
area you defined with the sound tool.
If you use an image as a poster for a sound object, you may have to resize the area to
conform to the dimensions of the image by clicking the poster with the Sound tool or
Select Object tool and then dragging the handles around the perimeter of the object until
the image is no longer distorted.
8. Click OK to finish adding the sound to the document and close the Add Sound dialog
box.
You can have a sound play when an image is clicked. This is useful when you want to augment
an image with a pre-recorded narration or perhaps a song. If you do not already have an image in
your document with which you wish to augment the sound, you can copy and paste an image into
your PDF document using the following steps:
1. In any application that contains an image (such as Adobe Photoshop), select the image,
and then choose Edit -> Copy. If using an image in another PDF document, use the
Select Image tool to select and copy the image.
2. Open the PDF document in which you want to past the image, and choose Paste
Clipboard Image from the Attachments menu on the Commenting toolbar.
3. Click the location in the PDF document where you want the image to appear.
4. Do any of the following:
• Using the Hand tool, drag the image to move it, or drag one of its handles to
resize it.
• To change the properties, right-click (Windows) or Control-click (Mac OS) the
image, and then choose Properties.
• To delete the image, right-click (Windows) or Control-click (Mac OS) the image,
and then choose Delete Comment.
To have a sound play when an image is clicked, follow these steps:
1. Select the Sound tool and create a hotspot around the image.
2. Choose Invisible Rectangle for the Appearance Tab.
3. From the Actions Tab, choose the mouse Trigger you wish.
4. Choose Play-A-Sound.
5. Select the sound you want to play when the image is clicked.
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Another method you can use to add sound to your PDF document is to create a button using the
Button tool (Tools -> Advanced Editing -> Forms -> Button Tool), and then assign a sound to
it. You can assign a sound to the Mouse Enter event to alert viewers that the button warrants
their attention or you can assign the sound to the Mouse Down event, which alerts the viewers
that the button has successfully been clicked.
You can also play a sound when a page opens or closes. Depending on the type of presentation
you create, you can have a short musical piece play when a page opens or have a vocal
introduction. This is done by adding actions to page Bookmarks and Thumbnails using the
Properties dialog box. To add page open or close action options follow these steps:
1. To open the Properties dialog box, select the Bookmark or page Thumbnail whose
properties you want to set or edit, right-click (Windows) or Control-click (Mac OS), and
choose Properties.
2. Leave the Appearance options as the default.
3. Click the Actions tab and add an Action from the Select Action drop-down list; select
“Go to a page in this document” if you wish to play an audio clip when the current page
opens. Click Add to add your selection to the Actions box.
4. If you wish to edit an action, select the action in the Actions box, then click the Edit
button. The only applicable option is “Use Page Number” where the page number is
specified. You can also select a different Zoom option from the drop-down list if you
wish, then click OK.
5. Do any of the following and then click Close.
• To delete an action, select the action, and click Delete.
• If you defined more than one action for a behavior, and if you want to reorder the
actions, select the action, and then select the Up or Down button.
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Adding Movies to a PDF Document
You can add movies to your PDF document by using the Movie tool. With Adobe Acrobat 6.0 or
7.0 Professional Edition you can embed the movie in the document, and you can specify
different renditions of the movie using different formats; for example, one rendition in the WMV
format for Windows Media Player and another rendition in the MOV format for the QuickTime
Player. See the Adobe Acrobat 6.0 (or 7.0) Professional Edition documentation for instruction on
adding and editing renditions.
By default, Acrobat 6.0 or 7.0 Professional Edition will snap the movie window to the size of the
movie and use the first frame of the movie as a poster in the document. To add a movie to a PDF
document, do the following:
1. Navigate to the page to which you want to add the movie file.
2. Choose Tools > Advanced Editing > Movie Tool, or select the Movie tool from the
Advanced Editing toolbar, whose icon looks like two frames of film.
3. Click and drag inside the document to specify the position in which the poster frame of
the movie will appear. By default Acrobat snaps the activation area to the dimensions of
the movie. This opens the Add Movie dialog box.
4. In the Content Settings section, choose Acrobat 6 (or 7) Compatible Media (the
default). If you select the Acrobat 5 (and earlier) compatibility, the options to embed the
movie in the document and create a poster from a file are no longer available.
5. Click the Browse button to open the Select Movie File dialog box; then select the desired
movie file and click Select to exit the Select Movie File dialog box.
6. Deselect the default Snap to Content Proportions option if you want to manually resize
the movie. The Embed Content in Document option must be checked.
7. In the Poster Setting section, choose one of the following options:
Use No Poster – Select this option to displays a rectangular border that defines the
activation area of the movie.
Retrieve Poster From Movie – Select this option (the default) to display the first frame
of the movie to signify the activation area for the movie.
Create Poster From File – Select this option to activate the browse button that, when
clicked, enables you to choose a supported file type that will be displayed as the
activation area for the movie. The selected file snaps to the dimensions of the movie if
you have not deselected the Snap to Content Proportions option.
8. Click OK to finish and close the Add Movie dialog box. Acrobat adds the movie to the
document and displays a poster according to the options you selected.
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Adding a Multimedia Presentation to a PDF Document
You can use Adobe Acrobat 6 or 7 Professional Edition to create a multimedia presentation or
automated slide show in a PDF document by including images, sound, video clips, Flash SWF
movies, etc. in your PDF document presentation.
If you have a PowerPoint presentation that you wish to include in a PDF document, the quickest
and easiest method is to do the conversion from within PowerPoint. You can also convert
Microsoft Excel spreadsheets to PDF documents using this same procedure. The computer you
use must have had Adobe Acrobat 6 or 7 Professional Edition installed on it after the Microsoft
Office installation. To convert a PowerPoint presentation or Excel spreadsheets to PDF format
do the following:
1. Choose Adobe > Change Conversion Settings to access the Acrobat PDFMaker dialog
box.
2. Modify the conversion settings to suit the intended destination of the converted PDF file.
3. Click OK to close the dialog box.
4. Click the Convert to Adobe PDF button, or choose Adobe PDF > Convert to Adobe
PDF.
After converting a PowerPoint presentation or Excel spreadsheet to PDF you can enhance it with
Acrobat features, such as adding hyperlinks, setting display time intervals between each
slide/page in the presentation, etc.
If you wish to create a multimedia presentation in a PDF document without the use of
PowerPoint or Excel, you can use Adobe Acrobat 6 or 7 Professional Edition to add multimedia
elements (including images, sound, video clips, Flash SWF movies, etc.) directly to PDF
documents. To automate such a slide show presentation you can use the setInterval JavaScript
object. Follow these steps to set the interval between each page of the presentation:
1. To assemble the images/elements you want to present, choose File > Create PDF >
From Multiple Files to open the Create PDF From Multiple Documents dialog box
and select the files to be assembled as separate pages of the PDF document.
2. In the File To Combine window, arrange the files in the order in which they will appear
and then click OK to convert the files to a PDF document.
3. In the Pages tab, select the first thumbnail, right-click (Windows) or CTRL-click
(Macintosh), and then choose Properties from the Context menu. When the Page
Properties dialog box appears, click the Actions tab; Page Open is selected by default.
4. Click the triangle to the right of the Select Action field and choose Run a JavaScript.
5. Click the Add button to open the JavaScript Editor dialog box.
6. Enter the following code in the Creat and Edit JavaScript text window:
var interval = app.setInterval(“this.pageNum = this.pageNum + 1;”, 3000);

6

7. Click OK to close the JavaScript Editor dialog box, and then click Close to exit the
Page Properties dialog box and assign the action to the page.
NOTE: Before going to the next step below, take a look at the JavaScript code in step 6
above. A variable named interval is created and set equal to the setInterval method of the
app object. The setInterval method is used to pause the application for a certain amount
of time, in this case 3000 milliseconds, which is equal to 3 seconds. The code in
quotation marks executes after the interval has passed. In this case, it increases the value
of pageNum property of the document by 1, which advances the document to the next
page. The code will continue to execute every three seconds until you stop the code by
clearing the interval.
8. In the Pages tab, select the thumbnail for the last page in the document and then rightclick (Windows) or CTRL-click (Macintosh) and choose Properties from the Context
menu. When the Page Properties dialog box appears, click the Actions tab; Page Open
is selected by default
9. Click the triangle to the right of the Select Action field, choose Run a JavaScript from
the drop-down menu, and then click the Add button to open the JavaScript Editor
dialog box.
10. Enter the following code in the Create And Edit JavaScript window:
app.clearInterval(interval);

11. Click OK to close the JavaScript Editor Dialog box. You now need to specify which
document will open next
12. Click the triangle to the right of the Select Action field, choose Open File, and then click
the Add button to open the Select File to Open dialog box.
13. Select the file that you want to open after the presentation plays: Click Select to select the
file and exit the Select File to Open dialog box, and then click Close to exit the Page
Properties dialog box.
When you use JavaScript, you can control the amount of time each page of the presentation is
displayed. To increase or decrease the interval time, enter a new value in Step 6, remembering
that 1 second equals 1000 milliseconds and thus you can precisely control the amount of time
each page is displayed.
At the end of the document, you can create two buttons: One to replay the show and one to exit.
For the Replay button, use the Execute Menu Item action and choose View > Go To > First
Page. For the Exit button, use the Execute Menu Item action and choose File > Close.
To enhance your multimedia presentation you can create a menu with multi-state rollover
buttons (using the Button tool) that play sounds, trigger movies, and much more. You can spice
up your presentation by adding interactivity to the Navigation menu buttons. You can add
additional interactivity to the button by assigning multiple actions.
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